Re: [isabelle] Problem with Leopard and XEmacs



Hi Peter,
I'm new with Isabelle, and last Friday I tried to install it for the first time.
To obtain the XEmacs interface, I type:

/usr/bin/Isabelle/bin/isabelle-interface

If I type only isabelle, it run the X11 window.
I hope that my aid works for you.

bye,
	Francesco


Il giorno 26/nov/07, alle ore 10:20, Peter Chapman ha scritto:

Hi

I've recently obtained Leopard, and the new version of Isabelle, and have got it all set up, except that when I type /usr/local/bin/ Isabelle, it opens up in an X11 window rather than in XEmacs (but proof general is already pre-loaded). XEmacs seems to work fine if you start it on its own; I've downloaded the version, via macports, which is suggested on the Isabelle website. On my old computer, I had used the fink installer, which installed xemacs in

/sw/bin

whereas macports installs it in

/opt/local/bin

So, after it didn't work, I created a symlink in /sw/bin, and then recompiled proofgeneral (I didn't know if this was necessary, but it didn't seem to harm anything; afterwards it all worked to the same standard as before, i.e. without XEmacs). I then tried editing the makefile that comes with ProofGeneral, but this was less than successful. Does anyone know if there is a variable in one of the various settings files that I can set so that my installation knows where XEmacs is?

Thanks

Peter







This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.