Re: [isabelle] Problem with Leopard and XEmacs



I don't understand how you can be runnning PG without XEmacs. Do you mean it is in GNU emacs in an XTerm window? I didn't know that was possible.

Anyway, when I installed Leopard, I noticed that MacPorts software no longer worked. The simplest way to update your MacPorts setup (especially if you only want XEmacs) is to delete /opt, then install a fresh copy of Macports, and finally install XEmacs by
	sudo port install xemacs +mule +sumo
If you have an old copy of /sw lying around, definitely delete that first. It can't be wise to use Fink and Macports at the same time.

Larry Paulson


On 26 Nov 2007, at 09:20, Peter Chapman wrote:

I've recently obtained Leopard, and the new version of Isabelle, and have got it all set up, except that when I type /usr/local/bin/ Isabelle, it opens up in an X11 window rather than in XEmacs (but proof general is already pre-loaded). XEmacs seems to work fine if you start it on its own; I've downloaded the version, via macports, which is suggested on the Isabelle website. On my old computer, I had used the fink installer, which installed xemacs in

/sw/bin

whereas macports installs it in

/opt/local/bin

So, after it didn't work, I created a symlink in /sw/bin, and then recompiled proofgeneral (I didn't know if this was necessary, but it didn't seem to harm anything; afterwards it all worked to the same standard as before, i.e. without XEmacs). I then tried editing the makefile that comes with ProofGeneral, but this was less than successful. Does anyone know if there is a variable in one of the various settings files that I can set so that my installation knows where XEmacs is?






This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.