[isabelle] Problems in isabelle installation



Hi

I get the below error when I try to use Isabelle in windows platform.

c:\Win16App\isabelle\Isabelle2008\bin>sh isabelle
C:/Win16App/isabelle/Isabelle2008/lib/scripts/getsettings 33: source: C:/Win16Ap
p/isabelle/Isabelle2008/bin/isabelle-interface 19: syntax error: got (), expecting {

when I remove "()" for all functions, I can at-least open the it in emacs but again gets the below errors in the commond promopt:

### White space in ISABELLE_HOME may cause strange problems later on!
### ISABELLE_HOME="C:/Win16App/isabelle/Isabelle2008"
type: C:/Win16App/isabelle/Isabelle2008/etc/settings 20: source: C:/Win16App/isa
belle/Isabelle2008/lib/scripts/getsettings 73: source: C:/Win16App/isabelle/Isab
elle2008/bin/isabelle-interface 19: Unknown option "-p"
type: C:/Win16App/isabelle/Isabelle2008/etc/settings 20: source: C:/Win16App/isa
belle/Isabelle2008/lib/scripts/getsettings 73: source: C:/Win16App/isabelle/Isab
elle2008/bin/isabelle-interface 19: Usage: type command ...
type: C:/Win16App/isabelle/Isabelle2008/etc/settings 83: source: C:/Win16App/isa
belle/Isabelle2008/lib/scripts/getsettings 73: source: C:/Win16App/isabelle/Isab
elle2008/bin/isabelle-interface 19: Unknown option "-p"
type: C:/Win16App/isabelle/Isabelle2008/etc/settings 83: source: C:/Win16App/isa
belle/Isabelle2008/lib/scripts/getsettings 73: source: C:/Win16App/isabelle/Isab
elle2008/bin/isabelle-interface 19: Usage: type command ...
type: C:/Win16App/isabelle/Isabelle2008/etc/settings 84: source: C:/Win16App/isa
belle/Isabelle2008/lib/scripts/getsettings 73: source: C:/Win16App/isabelle/Isab
elle2008/bin/isabelle-interface 19: Unknown option "-p"
type: C:/Win16App/isabelle/Isabelle2008/etc/settings 84: source: C:/Win16App/isa
belle/Isabelle2008/lib/scripts/getsettings 73: source: C:/Win16App/isabelle/Isab
elle2008/bin/isabelle-interface 19: Usage: type command ...

and after openning, it shows the below error in the "Proof General Welcome" Window:

"Please give the full path to `isatool' (RET if you don't have it): c:/Win16App/isabelle/Isabelle2008/bin/"

and then after pressing Enter it shows:

Warning (emacs): Proof General: isatool command not found; some menus will be incomplete and Isabelle may not run correctly.  Please check your Isabelle installation.

Could you please guide me about this problem?

I am using the below packages to run it in windows-XP (SP2)

HOL_x86-cygwin.tar.gz     
ProofGeneral.tar.gz
Isabelle2008.tar.gz       
polyml_x86-cygwin.tar.gz

which I downloaded from http://www.cl.cam.ac.uk/research/hvg/Isabelle/installation.html

I have emacs,perl and mks(for linux environment) installed in my PC.

Could you please help me solving this issue?


Thanks in advance
Best Regards
Manish Surolia


      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/






This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.