Re: [isabelle] Problems in isabelle installation



Hi,

Thanks for the reply.
I have downloaded the Cygwin and installed it in my PC.

and Isabelle is installed as below:

D:\DOCS\isabelle_setup_windows>tar -C C:\Win16App\isabelle\ -xzf Isabelle2008.tar.gz

D:\DOCS\isabelle_setup_windows>tar -C C:\Win16App\isabelle\ -xzf ProofGeneral.tar.gz

D:\DOCS\isabelle_setup_windows>tar -C C:\Win16App\isabelle\ -xzf polyml_x86-cygwin.tar.gz

D:\DOCS\isabelle_setup_windows>tar -C C:\Win16App\isabelle\ -xzf HOL_x86-cygwin.tar.gz

now I am facing some other problem.

emacs shows the below message when I run the commond: 
C:\Win16App\isabelle\Isabelle2008\bin>sh Isabelle

========Messsage================
command-line-1: Cannot open load file: /cygdrive/c/Win16App/isabelle/ProofGeneral/isar/interface-setup.el
========Message=================

Could you please help me to solve this issue also?

Thanks in advance
Best Regards
Manish Surolia


--- On Mon, 12/1/09, cl-isabelle-users-request at lists.cam.ac.uk <cl-isabelle-users-request at lists.cam.ac.uk> wrote:

> From: cl-isabelle-users-request at lists.cam.ac.uk <cl-isabelle-users-request at lists.cam.ac.uk>
> Subject: Cl-isabelle-users Digest, Vol 43, Issue 8
> To: cl-isabelle-users at lists.cam.ac.uk
> Date: Monday, 12 January, 2009, 9:30 AM
> Send Cl-isabelle-users mailing list submissions to
> 	cl-isabelle-users at lists.cam.ac.uk
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://lists.cam.ac.uk/mailman/listinfo/cl-isabelle-users
> or, via email, send a message with subject or body
> 'help' to
> 	cl-isabelle-users-request at lists.cam.ac.uk
> 
> You can reach the person managing the list at
> 	cl-isabelle-users-owner at lists.cam.ac.uk
> 
> When replying, please edit your Subject line so it is more
> specific
> than "Re: Contents of Cl-isabelle-users
> digest..."
> 
> 
> Today's Topics:
> 
>    1.   Problems in isabelle installation (manish surolia)
>    2. Re:  Problems in isabelle installation (Makarius)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sun, 11 Jan 2009 15:18:00 +0530 (IST)
> From: manish surolia <mani_surolia at yahoo.com>
> Subject: [isabelle]  Problems in isabelle installation
> To: cl-isabelle-users at lists.cam.ac.uk,
> isabelle-users at cl.cam.ac.uk
> Message-ID:
> <102221.65254.qm at web94812.mail.in2.yahoo.com>
> Content-Type: text/plain; charset=utf-8
> 
> Hi
> 
> I get the below error when I try to use Isabelle in windows
> platform.
> 
> c:\Win16App\isabelle\Isabelle2008\bin>sh
> isabelle
> C:/Win16App/isabelle/Isabelle2008/lib/scripts/getsettings
> 33: source: C:/Win16Ap
> p/isabelle/Isabelle2008/bin/isabelle-interface 19: syntax
> error: got (), expecting {
> 
> when I remove "()" for all functions, I can
> at-least open the it in emacs but again gets the below
> errors in the commond promopt:
> 
> ### White space in ISABELLE_HOME may cause strange problems
> later on!
> ###
> ISABELLE_HOME="C:/Win16App/isabelle/Isabelle2008"
> type: C:/Win16App/isabelle/Isabelle2008/etc/settings 20:
> source: C:/Win16App/isa
> belle/Isabelle2008/lib/scripts/getsettings 73: source:
> C:/Win16App/isabelle/Isab
> elle2008/bin/isabelle-interface 19: Unknown option
> "-p"
> type: C:/Win16App/isabelle/Isabelle2008/etc/settings 20:
> source: C:/Win16App/isa
> belle/Isabelle2008/lib/scripts/getsettings 73: source:
> C:/Win16App/isabelle/Isab
> elle2008/bin/isabelle-interface 19: Usage: type command ...
> type: C:/Win16App/isabelle/Isabelle2008/etc/settings 83:
> source: C:/Win16App/isa
> belle/Isabelle2008/lib/scripts/getsettings 73: source:
> C:/Win16App/isabelle/Isab
> elle2008/bin/isabelle-interface 19: Unknown option
> "-p"
> type: C:/Win16App/isabelle/Isabelle2008/etc/settings 83:
> source: C:/Win16App/isa
> belle/Isabelle2008/lib/scripts/getsettings 73: source:
> C:/Win16App/isabelle/Isab
> elle2008/bin/isabelle-interface 19: Usage: type command ...
> type: C:/Win16App/isabelle/Isabelle2008/etc/settings 84:
> source: C:/Win16App/isa
> belle/Isabelle2008/lib/scripts/getsettings 73: source:
> C:/Win16App/isabelle/Isab
> elle2008/bin/isabelle-interface 19: Unknown option
> "-p"
> type: C:/Win16App/isabelle/Isabelle2008/etc/settings 84:
> source: C:/Win16App/isa
> belle/Isabelle2008/lib/scripts/getsettings 73: source:
> C:/Win16App/isabelle/Isab
> elle2008/bin/isabelle-interface 19: Usage: type command ...
> 
> and after openning, it shows the below error in the
> "Proof General Welcome" Window:
> 
> "Please give the full path to `isatool' (RET if
> you don't have it):
> c:/Win16App/isabelle/Isabelle2008/bin/"
> 
> and then after pressing Enter it shows:
> 
> Warning (emacs): Proof General: isatool command not found;
> some menus will be incomplete and Isabelle may not run
> correctly.  Please check your Isabelle installation.
> 
> Could you please guide me about this problem?
> 
> I am using the below packages to run it in windows-XP (SP2)
> 
> HOL_x86-cygwin.tar.gz     
> ProofGeneral.tar.gz
> Isabelle2008.tar.gz       
> polyml_x86-cygwin.tar.gz
> 
> which I downloaded from
> http://www.cl.cam.ac.uk/research/hvg/Isabelle/installation.html
> 
> I have emacs,perl and mks(for linux environment) installed
> in my PC.
> 
> Could you please help me solving this issue?
> 
> 
> Thanks in advance
> Best Regards
> Manish Surolia
> 
> 
>       Add more friends to your messenger and enjoy! Go to
> http://messenger.yahoo.com/invite/
> 
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Sun, 11 Jan 2009 13:58:20 +0100 (CET)
> From: Makarius <makarius at sketis.net>
> Subject: Re: [isabelle] Problems in isabelle installation
> To: manish surolia <mani_surolia at yahoo.com>
> Cc: isabelle-users at cl.cam.ac.uk
> Message-ID:
> 	<Pine.LNX.4.64.0901111356120.7731 at macbroy21.informatik.tu-muenchen.de>
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> 
> On Sun, 11 Jan 2009, manish surolia wrote:
> 
> > I get the below error when I try to use Isabelle in
> windows platform.
> > 
> >
> c:\Win16App\isabelle\Isabelle2008\bin>sh
> isabelle
> >
> C:/Win16App/isabelle/Isabelle2008/lib/scripts/getsettings
> 33: source: C:/Win16Ap
> > p/isabelle/Isabelle2008/bin/isabelle-interface 19:
> syntax error: got (), expecting {
> 
> > I am using the below packages to run it in windows-XP
> (SP2)
> > 
> > HOL_x86-cygwin.tar.gz     
> > ProofGeneral.tar.gz
> > Isabelle2008.tar.gz       
> > polyml_x86-cygwin.tar.gz
> > 
> > which I downloaded from
> http://www.cl.cam.ac.uk/research/hvg/Isabelle/installation.html
> > 
> > I have emacs,perl and mks(for linux environment)
> installed in my PC.
> 
> MKS is the problem.  You really need Cygwin here, with full
> bash and perl, 
> and regular Posix semantics of everything.
> 
> Also make sure that packages "xinit" and
> "xterm" of Cygwin are installed 
> -- the Cygwin/X people have changed a few things recently.
> 
> 
> 	Makarius
> 
> 
> 
> 
> End of Cl-isabelle-users Digest, Vol 43, Issue 8
> ************************************************


      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/






This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.