Re: [isabelle] Isabelle/jEdit: can anybody else reproduce



Hi Alasdair,

I haven't tried the latest repo version, but had previously tried
applying the various workarounds from that thread to my xmonad.hs with
no success. I wrote it off at the time because that issue refers to
older JDKs and problems that I don't have. E.g. some of the applications
they mention run fine on my machine.

It's possible the fix does something different than the workarounds.
I'll try the repo version and see what happens. Thanks for the tip!

Matthew

On 22/03/13 01:07, Alasdair Armstrong wrote:
On 21 March 2013 06:13, Matthew Fernandez
<matthew.fernandez at nicta.com.au> wrote:
I have a similar issue [0], that Makarius has indicated is an interaction between Xmonad and this version of the JDK. However, unlike Christian's problem mine is consistently reproducible. Interestingly I have had no issues with other Java apps on this JDK or with standalone jEdit, but this may just be coincidence.

[0]: https://bitbucket.org/isabelle_project/isabelle-release/issue/11/linux-jedit-allows-no-editing-of-opened

Dear Matthew,

I think I have had the same problem as you - are you using the latest
version of xmonad from the darcs repository? I think most of the input
and focus issues with xmonad and Isabelle/jEdit are related to this
bug in xmonad:

http://code.google.com/p/xmonad/issues/detail?id=177

This bug was fixed very recently in the latest development versions,
and upgrading solved all my jEdit issues (bar the standard java not
playing nicely with non-reparenting window manager problems).

Best,
Alasdair


________________________________

The information in this e-mail may be confidential and subject to legal professional privilege and/or copyright. National ICT Australia Limited accepts no liability for any damage caused by this email or its attachments.




This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.