Re: [isabelle] Unable to get document preparation system to work



Just wanted to pop this up again as the issue persists with 2014-RC4 and comment.sty version 3.7 is in the stable branch of tex live.

Best
    Benedikt

Am 31.01.14 19:44, schrieb Makarius:
On Wed, 29 Jan 2014, Makarius wrote:

On Wed, 29 Jan 2014, James Lingard wrote:

>    comment.sty   9666    2014-01-23 07:36:21
>
That's weird. The copyright at the top of the file says July 2009. If it
 really is brand new then that explains why I might have been the first
 person to run into this.

So from where did you get that version? TeXlive is not there yet, luckily.

I use myself CTAN only as occasional reference, but have no idea how it is actually maintained. There is also no immediately visible changeset history, with names of authors etc.

Maybe it is just an accident, with some experiment that someone made at some point, to the anoyance of plain TeX users.

I've looked again more closely at CTAN: the situation of http://www.ctan.org/tex-archive/macros/latex2e/contrib/comment is a bit odd, because comment.sty has been copied over with that 3.7 version from 2009, while everything else is still saying 3.6, including the documentation (which claims that the package works with Plain TeX).

I've also tried again if it is feasible to run in regular LaTeX mode, but then it is very slow, as already noticed in 2005, when I made this setup for isabelle.sty.


So the present conclusion of this thread: Anybody who happens to be on a latest-testing-unstable branch of some TeX installation can put a copy of the included comment.sty 3.6 into $ISABELLE_HOME/lib/texinputs/. The Isabelle document preparation system will copy it from there into the document output directory, so that version should take precedence.

The next Isabelle release will probably have that comment.sty 3.6 as well, but that is still several months ahead.


    Makarius





This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.