Re: [isabelle] Isabelle2015: install problem on Win 7



On Fri, 19 Jun 2015, Colin Rowat wrote:

I've just downloaded Isabelle2015 for Windows (7, 64-bit), and encounter
the following error when attempting to install it:

Failed to create directory:
"U:\.isabelle\Isabelle2015\heaps\polyml-5.5.2_x86-cygwin\log

At this point, Isabelle system initialization ends.

Thus, the problem is that Isabelle's installer is looking for a network
drive to which I'm not attached.

What exactly does it mean to be not attached? Is this a directory that is sometimes on, and sometimes off? So is it possible to reconnect that?

Did you manage with Isabelle2014? There should be very little difference to Isabelle2015.


Anyway, what the Isabelle system environment tries here is to refer to the canonical user home directory as determined by HOMEDRIVE and HOMEPATH (see also https://en.wikipedia.org/wiki/Environment_variable#Windows). The result is stored in the USER_HOME environment variable in Cygwin notation, e.g. /cygdrive/u/.isabelle/Isabelle2015 for the above.

You can change that globally for all applications of your user account in the Windows Control Panel for "Environment Variables". Just create a new entry like this:

  USER_HOME
  /cygdrive/c/Users/Colin

Assuming that this is your local machine home directory. You can use any other directory that you see fit, but note that it will be the location for "~" in Isabelle path specifications.


	Makarius




This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.