[isabelle] Isabelle's environment and external executables



Hi all,

Iâm calling some external (Haskell) executables from inside Isabelle. If I start isabelle from the shell (using the command âisabelle jeditâ) it works fine, and my executables are picked up from my bash environment as theyâre in the PATH. However, if I start Isabelle by double-clicking, the environment is different, and Isabelle no longer finds what is in my normal path.

Iâve consulted the Isabelle Systems Manual, and tried to follow the instructions to add the paths to the ISABELLE_TOOLS environment variable in my $ISABELLE_HOME_USER/etc/settings, but that does not work. Iâve also tried adding the path to $ISABELLE_HOME_USER/etc/components but that made no difference either. 

Obviously doing something silly but wrong, as it should be easy to add something to Isabelleâs environment.

Here are the gory details, my Isabelle extension is looking for two executables called âHipSpecifyerâ and âhipster-hipspecâ, but fails to find them: 

/var/folders/sl/hb1d9hld2tsfgn33xgsxt1lc0000gp/T/isabelle-moajohansson3147/bash_script1000488: line 1: HipSpecifyer: command not found 
/var/folders/sl/hb1d9hld2tsfgn33xgsxt1lc0000gp/T/isabelle-moajohansson3147/bash_script1000491: line 1: hipster-hipspec: command not found

Best,
Moa


This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.