Re: [isabelle] Isabelle/Jedit not recognising theories in menu



Hi Makarius,

Thanks for your response.

It is definitely an Apple Magic Mouse 2 (bluetooth mouse)
interaction with Isabelle2016-1 on Mac OS X Sierra.
I also get the same issue with the old Isabelle2016.
Both used to work fine.

I only updated to Sierra on 25 Jan and the problem may have
arrived with that. I first noticed it within the last week but I may
not have been using Isabelle in the period after I upgraded to Sierra.

The problem is only double clicking file names in the theories menu.
Double clicking within the file works and highlights the selected
word as expected. Are these handled differently?
Occasionally it does work, maybe just the first time after restarting Isabelle.

Double clicking said mouse in my mailer works just fine
(as do all the other apps I've tried).

Confusingly, I got out my old USB mouse and double clicking
in Isabelle works as expected with it all the time,
so it is just the magic mouse.

I've tried setting the double-click duration in the mouse preferences
and it makes no difference.

In summary the problem seems to require a Magic Mouse and Sierra on a Mac.

I'm very confused by the behaviour.
Ian

On 10/2/17 11:54 pm, Makarius Wenzel wrote:


On 09/02/2017 06:09, Ian Hayes wrote:

After I start up Isabelle and load some theories
I can no longer switch between theories by clicking
on the theory name in the theory menu.

I'm using Isabelle2016-1 on a Mac (Sierra).
I've tried reinstalling Isabelle2016-1 and
removing .isabelle/Isabelle2016-1 from my home.

I have now a new test machine (Mac mini Late 2014) so I can check this first-hand on Sierra: it all looks fine after 10min of experimentation.


Are there some separate magic files for jedit that have
become corrupted?

The persistent state of the Isabelle application is normally confined to $ISABELL_HOME (inside the .app directory) and $ISABELLE_HOME_USER (inside $HOME/.isabelle).

My guess is that there are some general OS or desktop settings involved. The "Theories" panel requires a double click to jump to source files. May the global mouse configuration changed accidentally, due to other reasons than Isabelle.

Apple might have more ways to change certain GUI behaviour, but I am only a part-time Mac user and can't tell for sure.


    Makarius





This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.