Re: [isabelle] Issue launching jEdit for multiple Isabelle versions



A user to user point of view:

JEDIT_SETTINGS is a shortcut for the directory where your, well, jEdit settings are present. (It can be found using the super useful and probably underestimated File/Open/Favorites in jEdit).

When I installed Isabelle2020 and Isabelle2021 those directories (Windows) are, respectively,
C:\Users\StepanHolub\.isabelle\Isabelle2020\jedit
and
C:\Users\StepanHolub\.isabelle\Isabelle2021\jedit

Your folders seem to coincide. I do not know what you did to achieve that, but it does not seem to be standard.

Best

Stepan


On 31-Aug-21 5:58 PM, Thomas Sewell wrote:
Thanks, that clears up what the problem is.

I seem to be able to (crudely) switch versions by clearing some of those jars, and I take it I can make things work consistently by setting up JEDIT_SETTINGS
to be unique per Isabelle instance on my machine. I dimly recall a
similar issue with PolyML heaps in the past.

I'll just say that this doesn't seem ideal. If I've somehow entered an officially unsupported non-default configuration, I ought to at least be aware I've done that. I've never heard of JEDIT_SETTINGS, or set it, and there's barely any information
about it anywhere I can find. Maybe this could be improved?

Best regards,
    Thomas.

On 2021-08-31 15:05, Makarius wrote:
On 31/08/2021 13:59, Thomas Sewell wrote:
Today I tried to launch Isabelle/jEdit and encountered some kind of
fundamental issue
with loading of Java classes. This seems to apply to multiple versions of
Isabelle,
including 2020 and 2021 instances. This is very strange, because I think
they're using
different jdk and jedit components, and they worked in the past.

It seems like you are reusing the same JEDIT_SETTINGS directory for all these different versions (which is at your own risk and not officially supported).


The relevant error is this:

The errors show a conflict of a new Isabelle/jEdit pluging
12:42:05 [main] [error] PluginJAR: Error while starting plugin
isabelle.jedit_base.Plugin
12:42:05 [main] [error] PluginJAR: java.lang.NoClassDefFoundError:
isabelle/jedit/Base_Plugin

The corresponding jar file is:

/home/tsewell/.isabelle/jedit/jars/isabelle_jedit_base.jar


But this plugin jar belongs to recent isabelle-dev versions, e.g.
https://isabelle-dev.sketis.net/rISABELLEfc363a3b690a --- this changes the
overall directory, component, and plugin arrangement for Isabelle/jEdit

By removing some files from $JEDIT_SETTINGS it should work again for the
official Isabelle releases:

  jars/isabelle_jedit_base.jar
  jars/isabelle_jedit_main.jar
  jars-cache/

Maybe some more ...


    Makarius



--
Tento e-mail byl zkontrolován na viry programem AVG.
http://www.avg.cz





This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.